A problem occured while creating issue


#1

Received the following when I tried to create my first case in Jira from a failed test:

Error: FetchError; request to https://“our_jira_ip”/rest/api/2/issue/createmeta/? expand=projects.issuetypes.fields failed, reason: Hostname/IP does not match certificate’s altnames: IP: “our_jira_ip” is not in the cert’s list.
I checked the webtstit.json but do not see a section on certificates so not sure where to look next. We are using Jira server installed on our own server.


#2

Hello @jmsc7ran!
Have you set up the Use SSL and Protocol options in the Preferences -> Jira integration menu?
If that is the case, and the error is still there, possibly there is an issue in your Jira’s certificate (as the error says), and you could take a look at this post on the official atlassian page for possible solution.
Kind regards


#3

Thank you for the reply, you got me thinking in the right direction. In the Jira connection information I had specified the IP address instead of the hostname. The test connection worked with the IP address but in order to create a ticket it needs the hostname to resolve the certificate. Once I changed it to the hostname it worked. Thanks again!


#4

@jmsc7ran
Nice to hear it worked out for you.
What we will do is to update instructions and field descriptions on how to connect with Jira, to avoid possible confusion in future.
Regards!


closed #5