Chrome Error during launch of browser


#1

Hi all:
I am getting this error at the beginning of a test-- I am running Chrome 76.0.3809.132. I get this error when Webtestit attempts to actually launch the browser to begin the test. “… Failed to create a Chrome Process”


#2

hello micheleaz!
Could you please provide us with some additional information regarding this problem:

  • Is this happening every time you try to run a test on Google Chrome
  • Is this happening on every project, Java, TypeScript (you could perhaps just quickly try to download and run our sample projects and see if they work)
  • Did this error occurred with the update to the v1.5.0 version of Ranorex Webtestit or have you had this issue before.

Thank you for your feedback and sorry for the inconvenience,
Best regards.


#3

Hello:

  1. Yes it happens every time.
  2. This happens with every project. I downloaded your Typescript demo and I will attach the error I got when I tried to compile with chrome as an endpoint.
  3. Yes this error happened with the previous version as well.

#4

Hello @micheleaz
What NodeJs version are you using? Could you try to update your node version to the latest one and check again.
Also, seems like there is an issue with downloading/starting the chromeDriver. Could you check if the chromeDriver was downloaded in your installation folder of Ranorex Webtestit under \webtestit\vendor\drivers\chromedriver folder and if the driver is there could you delete it and try to start the test again?
Regards


#5

Hello:
I downloaded nodeJS especially for this issue as we are programming in Java. The version I had downloaded to try your demo is v.10.16.3-x64.

The chrome driver is in the drivers folder. The version number initially is 76.0
.3809.126-x64.I deleted the file and tried again. I got the same error. The driver did not download again after I compiled. That folder is still empty.


#6

hello @micheleaz!
This issue can occur if your Google Chrome browser is set to run in administrator mode, so java can’t start it.
Could you check if your chrome is set to run as an administrator and un-check this option if it is enabled, and give it another try?


Regards


#7

This is going to be a problem as I have ranorex studio on this computer and when you install Ranorex studio, it also installs a chrome plugin that enables this setting…


#8

I uninstalled the Ranorex plugin and tried it. That fix works. I also reinstalled the Ranorex plugin and it seems to be working after the install. I also tried running a ranorex web test… It seems to work OK (but slow) without that setting checked. You might check with your counterparts on the Ranorex side to see if that setting is a must for them…


#9

Wow what an adventure to figure that out. We’re super happy you took the time to dig in, thanks @micheleaz. Yep we’ll definitely have a chat with our colleagues in order to see what we can do about that.


#10

Ok so we’ve just created a fresh VM, installed Chrome and installed the latest Ranorex Studio version, including the Chrome Plugin during installation. Also setup a fake test just to try it out.
Chrome is not set to admin mode in compatibility. So it must be that this got in your settings somehow differently. Maybe you’ve followed along an article for something Studio related, which required the Admin permissions?


#11

Yes, I believe we had issues initially when setting up some web tests and someone on the ranorex side that I had to enable chrome to run as an admin… I believe that fix came from their help desk.


#12

ah ok, yeah that makes sense. Anyways good that this got resolved, thanks again for your feedback @micheleaz


closed #13