Mobile Emulation support


I found this article for ChromeDriver Mobile Emulation:

To make this feature work via endpoint configuration would be pretty cool.
Tough I managed to get my tests running on a native Android smartphone it would make things much easier at development time. There is also no out of the box solution to test on IOS devices.

Release notes v1.4.0

Hello @HRA!
An interesting Feature Request indeed. We will discuss this request internally and see what we can do about it. Currently, Ranorex Webtestit supports only Android devices as an endpoint, but a good thing is that we have the Appium integration in our long-term plans.
Thank you for your feedback!


Hello @HRA
In this article, we’ve explained how to enable mobile emulation via endpoint configuration in Ranorex Webtestit:

We hope you’ll find it useful.

Thank you again for your feedback!


Hi @nmitrovic
I tried the described solution but unfortunately it is not working for me.
Running on Windows 10 with Chrome Version 75.0.3770.100 (Offizieller Build) (64-Bit) it always ends shortly with this message:
My endpoint configuration looks like that:

Its noticeable that WebTestit detects a 32 bit Chrome. Installed is 64bit (version is correct).
Here is the content of default.endpoint.json file:

The other endpoint works fine. I also tried other device names for emulation - all without success.


Hi @HRA!
Seems like there is a small issue with this on Windows. Let us take a look and let you know the outcome :slight_smile:


An update on this:
First of all, thank you for your feedback, we could identify a small issue here thanks to you.
The issue is regarding the whitespace in the "deviceName" value like in this example "Nexus 5", that needs to be handled differently and we somehow overlooked.
This issue is related to Java projects on Windows OS only, and If you try to run the test with “iPad” as a value (a device name that has no whitespace in it), it should pass.
We have this in our backlog and it should be fixed with the next release.
Kind regards!


Hello @smatijas,
thanks for the quick reply. Indeed it works with “iPad” as value. Seems like most people out there are Linux/Mac and Javascript guys :wink: I am looking forward to the next release :slight_smile:


Fixed with release v.1.4.0

closed #9