Tests on IE and Edge fails

bug-report

#1

Reporting against Webtestit version 0.24.0

Tests with endpoints IE and Edge failed

Steps to reproduce
Install WT on windows 10
Download Java sample project
Add IE and Edge endpoints
Run the tests

All tests against IE and Edge failed

IE
image

Edge
image


#2

Ok @janesh. We will have a look on this. Have you set up all that is required for IE like described in this post? Make sure to set default zoom to 100% on IE, set up FEATURE_BFCACHE. It should work fine then. Note that IE needs a bit more time to run


#3

Hi @smatijas
It was due to not setting the protected mode in ALL zones in the Internet Explorer settings.

BTW how about Webtestit taking care of these settings for the user.

        InternetExplorerOptions options = new InternetExplorerOptions();
        options.ignoreZoomSettings(); //Ignoring the Zoom level setting 
        options.introduceFlakinessByIgnoringSecurityDomains(); //Ignoring the Security domains settings 
        options.disableNativeEvents(); //Disabling the NATIVE_EVENTS capability to ensure the typing speed with 64bit driver 
        //Launch IE browser
        WebDriver driver = new InternetExplorerDriver(options);

Thanks


#4

thats actually a really good idea. @smatijas let’s check out whether applying that in the base configuration removes the need for manual configuration.


#5

Yes, we can definitely include this in our default configuration for Internet Explorer and make the life of those who are testing on IE easier :slight_smile: We will put this in our backlog .


#6

@smatijas
Thanks for the consideration.
Please consider closing the info-bars in Google Chrome too.