Warning from npm package



While opening a project there is a warning popping up in the log that the wrong typescript version is installed. It seems that the package “tslint-language-service” is depreciated and replaced with this one: “typescript-tslint-plugin”

npm WARN [email protected] requires a peer of [email protected]>= 2.3.1 < 3 but none is installed. You must install peer dependencies yourself.

Windows 10 64-bit desktop PC
Webtestit 1.10


Hi @TSKdx!
Thank you for your feedback!
I will notify the team, and we will look into it and see what is going on with the ts-lint service. As I managed to check it out quickly, the service seems to be working even with this warning. If you face any functionality issues please don’t hesitate to report it.
Kind regards


Yes there are a few changes around TSlint, thus also the language services surrounding it. While the warning is there, it is exactly what it is. a warning :slight_smile:
We’re going to change this with a future update but until then you can fix it yourself by doing the following steps:

  1. Open your project in Ranorex Webtestit
  2. Open the file package.json and search for the line "tslint-language-service": "^0.9.9",
  3. Replace it with "typescript-tslint-plugin": "^0.5.5", and save the file which will automatically install the new and remove the old dependency.
  4. Open the file tsconfig.json and replace the plugins name section to read like this:
"plugins": [
    "name": "typescript-tslint-plugin"
  1. Save the file, close and reopen your project to be on the safe side.

with that done you should now no longer see the issue yet have the same features as before.